CentOS – Unexpected inconsistancy run fsck manually” at every boot


CentOS – Unexpected inconsistancy run fsck manually” at every boot Continue reading “CentOS – Unexpected inconsistancy run fsck manually” at every boot”

Advertisements

Install vagrant on CentOS


[root@localhost chef-technical-kitchen]# gem install vagrant
Fetching: vagrant-1.5.0.gem (100%)
Thanks for wanting to use Vagrant! Unfortunately, this is not the way
to install Vagrant anymore. We now make installers for the various operating
systems Vagrant supports. Continue reading “Install vagrant on CentOS”

Install berkshelf on CentOS 6.x


Berkshelf is used as the bundler for rubygems – it manages cookbooks and their dependencies.

To install Berkshelf,

[root@localhost chef-technical-kitchen]# gem install berkshelf –no-ri –no-rdoc
Fetching: nio4r-1.0.1.gem (100%)
Building native extensions.  This could take a while…
Successfully installed nio4r-1.0.1
Fetching: hitimes-1.2.2.gem (100%) Continue reading “Install berkshelf on CentOS 6.x”

Install Ruby 2.0 on CentOS 6.x


rvm get head (to get the latest version of rvm)

[root@localhost ~]# rvm install 2.0.0
Searching for binary rubies, this might take some time.
No binary rubies available for: centos/6/x86_64/ruby-2.0.0-p598.
Continuing with compilation. Please read ‘rvm help mount’ to get more information on binary rubies.
Checking requirements for centos. Continue reading “Install Ruby 2.0 on CentOS 6.x”

How to Install Ruby, Ruby Gems, and Rails on CentOS 7


We have moved this post to http://etutorialsworld.com/2016/03/install-ruby-ruby-gems-and-rails-on-centos-7/

ERROR: Error installing rails: i18n requires Ruby version >= 1.9.3.


Post is moved -> Solved Error installing rails: i18n requires Ruby version >= 1.9.3

GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag


To solve: GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag

Run following command in terminal: Continue reading “GPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag”